Sunday, February 19, 2012

Open source web testing and automation framework

10, 9, 8 ... ignition sequence start ...
3, 2, 1, zero ... All engines running. Lift-off! We have a lift-off.




I am happy to announce Open Twebst, open source web testing and automation framework!

http://open-twebst.codecentrix.com/

Get it while it's hot!

Happy web automation to y'all!

8 comments:

W1ckd said...

very nice, however i got the error: "It Seems that "Open Twebst" is not properly installed! Please Re-install the Product", anyone a soluction?

Adrian Dorache said...

Do you have admin rights on the machine? I suspect that somehow the installer failed to register COM components.

Try to open an elevated command line and execute the following commands:

regsvr32 OTWBSTPlugin.dll
regsvr32 OpenTwebstLib.dll

Let me know if it works.

W1ckd said...

Thank you for your respons! I have indeed limited acces to this computer, would it help when run the installer with "run as administrator" ? the both files give the error: The Module "" was loaded but the call to dllregisterserver failed with error code 0x90070005 for more, Ill try search arround to find a bypass :) Thank you in advance! :)

Adrian Dorache said...

Try to run the installer as admin. I tested the setup with a non admin, standard user on Windows 7 and it asked for admin credentials.

What is your Windows version?

W1ckd said...

haha, my laptop crashed so i need to get it repaired on monday, however i tried to install it on my stationairy pc and it went witouth problems, However, after recording and trying to open the written code it gives the error: The ordinal 410 could not be located in the dynamic link library urlmon.dll. any idea how to fix this one?

Adrian Dorache said...

So, I understand the recorder generated some code after all.

I don't understand what do you mean by "trying to open the written code". Did you press "Run" button?

What was the language for the generated code?

What is your Windows and IE version?
Can you share a snapshot with the error message please?

W1ckd said...

After installing the application with admin right all the things are working like it should! :) so thank you, i am running btw windows vista with ie 7. I understand that the scripts i generate can be only ran on a computer with Twebst installed? or can i somehow include the core in the script?

Adrian Dorache said...

You need to install Twebst in order to run the scripts.